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In this handout, we will considers some basics including generating data and creating, customizing, and 
manipulating graphs that we use in creating interactive workbooks using MS Excel. 
 
Customizing the MS Excel Window:  You may find it helpful to customize your MS Excel environment by 
adding toolbars and toolbar buttons that you will use frequently.  To do this, you may use the Customize option 
on the Toolbars menu of the View menu, the Customize option on the Tools menu, or use one of the down-
arrows at the end of a displayed toolbar, selecting Add or Remove Buttons and then Customize at the bottom of 
the drop down menu.  Figure 1 displays an example of the drop down menu for the Control Toolbox Toolbar that 
is generated by left-clicking the arrow at the end of this toolbar.  Depending on the version of MS Excel that you 
are using, the individual toolbar buttons may be displayed in a slightly different manner but each version of MS 
Excel will include the Reset Toolbar and Customize options on this drop down menu in some manner. 
 

  
Figure 1:  The Add or Remove Buttons drop down menu from 

the Control Toolbox Toolbar. Figure 2:  Customize Dialog Box. 

 
Using the Customize dialog box, you can select the toolbars that you want to display.  As you can see in Figure 
2 above, some of the toolbars that I frequently use include the Standard, Formatting, Control Toolbox (of 
course), Drawing, Exit Design Mode (convenient to have an extra exit for design mode other than the one on the 
toolbar), Full Screen, and Picture.  You can also create your own toolbars displaying 
 

  
Figure 3:  The Commands Tab. Figure 4:  The Options Tab. 
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toolbar buttons that you frequently use.  Using the Command tab, you can add buttons to any toolbar, including 
toolbars that you create.  To add toolbar buttons, simply select the category, left-click, hold, and drag the toolbar 
button to the desired location among the displayed toolbars, and release – the new toolbar button will be 
displayed in the selected location.  One toolbar button that you will find helpful to add is Toggle Grid.  Toggle 

Grid, , allows you to easily turn off the grid lines.  The Toggle Grid button is displayed in the Command 
window corresponding to the Forms Category, Figure 3.  Another way in which to turn off the grid lines is to 
uncheck the Gridlines box displayed on the View tab in the Options dialog box that is displayed by selecting the 
Options entry on the Tools menu, Figure 5; if you plan to use the elements on the Forms Toolbar then you will 
have easy access to the Toggle Grid button. 
 

Figure 5:  View tab in the Options Dialog Box. Figure 6:  My Laptop’s MS Excel Window. 
 
Unchecking the Standard and Formatting toolbars share one row box on the Options tab of the Customize 
dialog box, Figure 4, will allow you to see all the basic toolbar buttons rather than having to search for them at 
the end of the top row of toolbar buttons. 
 
It is important to mention that displaying toolbars will reduce the amount of the worksheet that you can view in 
the MS Excel window, Figure 6.  However, if you use particular design elements frequently, having access to the 
toolbars and the toolbar buttons will be very helpful.  Since the adding and removing toolbars is very easy, it is 
not a problem either way. 
 
 
Generating Data:  The auto fill feature in MS Excel is very helpful in generating data for graphs.  While many 
folks like to start the sequence of inputs/outputs and then let MS Excel fill in the rest, I have found it very helpful 
to control the auto fill – this minimizes possible errors.  There are two methods that I use a great deal:  the first 
involves formulas and a start-value, and the second involves formulas, a start-value, and cells containing 
parameters. 
 

  
Figure 7:  The inputs, differing by 0.1, are all dependent on the 

start-value in cell A1. 
Figure 8:  In turn, the outputs are dependent on the start-value 

in cell A1. 
 

© 2006 Sarah L. Mabrouk 2 
 



Using formulas and a start-value allows you to control and adjust the data as desired since both the inputs and 
the outputs are dependent upon the start-value.  In Figure 7, the start-value of –5 is entered in the first cell of 
input column A, cell A1.  Using the formula, =a1+0.1, we can create inputs that differ by 0.1 and can be adjusted 
simply by changing the start-value.  In Figure 8, the first output formula is entered, =a1^3+16*a1.  Of course, this 
output is dependent upon the start-value in cell A1.  Using the auto fill to generate the output in cell B2, we can 
then select and drag the formulas in cells A2 and B2, Figure 9, to generate the desired data, Figure 10; to 
generate the inputs from –5 to 5, inclusive, we drag to row 101. 
 

  
Figure 9:  Dragging the formulas in cells A2 and B2. Figure 10:  The data generated using the auto fill. 

 
After generating the data, you can easily change the inputs and the output simply by changing the start-value.  
In Figure 11, the start-value is –5 but changing the start-value to 7 changes both the inputs in column A and the 
outputs in column B, Figure 12. 
 

  
Figure 11:  Start-value of –5 in cell A1. Figure 12:  The data when the start-value is changed to 7. 

 
Using a start value will allow you to easily adjust the data as desired without having to reenter the data.  Since 
the values in columns A and B are determined by formulas that depend on the value in cell A1, changing this 
value, for example from -5 in Figure 11 to 7 in Figure 12, changes all values in these columns. 
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Of course, to make adjusting the data even easier, you could enter the values of the parameters that you would 
like to control in selected cells; if you want to be able to use these values later, you will find it helpful to label 
them on the worksheet.  So, for example, instead of using a fixed increment of 0.1 as we have above, we could 
put the incremental value for the data in a cell and then reference this cell value in place of the 0.1 that we used 
above. 
 
Let us put our start-value, -5, in cell D1, and the coefficients of our cubic function, , in cells E1, F1, 
G1, and H1, respectively, Figure 13.  It is important to remember to use $’s around the cell letter to fix the cells 
otherwise the auto fill will affect the row number for the parameters in the formulas.  If you want to control the 
change in input, previously set as 0.1, you can store that in a cell as well; here, we will put our input-change in 
Cell J1. 

3y x 16x= −

 

  
Figure 13:  The start-value and the coefficients of the function 

entered in cells D1, E1, F1, G1, and H1, respectively. 
Figure 14:  The start-value is entered in cell A1 using a 

formula, =$d$1. 
 
We enter the formula for cell A1, =$d$1, Figure 14, to set the start value, and then enter the formula, =a1+$j$1, 
Figure 15, in cell A2.  When we use the auto fill, the formula in cell A2 will generate the inputs. 
 

 
Figure 15:  The input formula that uses the start-value and the 

input-change, =a1+$j$1, is entered in cell A2. 
Figure 16:  The output formula, =$e$1*a1^3 + $f$1*a1^2 + $g$1*a1 + 

$h$1, is entered in cell B1. 
 
We enter the output formula, =$e$1*a1^3+$f$1*a1^2+$g$1*a1+$h$1, in cell B1, Figure 16, and use the auto fill 
to generate the output for cell B2.  Examining the entry in cell B2, Figure 17, we see that the auto fill did not 
change the row numbers for which we used $’s – these, as desired, remained fixed. 
 

 
Figure 17:  The auto fill is used to generate the entry in cell B2. Figure 18:  The auto fill produces the “same” entry in cell B3. 

 
Then, as before, we can use the auto fill to generate the number of desired input-output pairs; here, as before, 
we will generate 101 points.  Having generated the data, we can change the data by changing any of these 
parameter values. 
 
 
Creating a Graph:  Now that we have two sets of data, one for which we can control the start-value and the 
other for which we can control the start-value, input change, and output function parameters, we are ready to 
generate some graphs. 
 
Let us graph our first data set.  We select the data that we want to graph, the data between rows 1 and 101, 
inclusive, in columns A and B.  We open the Chart Wizard using either the Chart entry on the Insert menu or the 

Chart Wizard toolbar button, .  The first step of four (4) is to select the graph type.  Since we would like to 
create a curve that connects our data points without markers, we select the XY (Scatter) and “Scatter with data 
points connected by smoothed Lines without markers”, Figure 19.  The second step allows you to check the 
data series.  We use the Data Range tab, Figure 20, to check that the location of the data, in columns A and B 
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between rows 1 and 101, inclusive.  We can use the Series tab , Figure 21, to change the data series as we 
could on the Data Range tab, to name the data set, and to add and to remove series from our graph simply by 
specifying the location of the data.  Here, let us name this data series “First Set”, Figure 22. 

  
Figure 19:  Step 1 – Select the chart type. Figure 20:  Step 2 Data Range tab – the Data range and the 

location of the series, Rows or Columns. 
 
After entering the name for our data series in the Name box, the name will appear in the Series box as well as in 
the graph legend, Figure 22.   
 
In general, I find that naming the data series makes dealing with the data more complicated.  I chose to name 
the series here so that you will have an opportunity to see how to name and then rename a series.  For our 
renaming of the series, it is important to note that the original name of the series was “Series1”.   
 
When I create a graph containing only one data set, I never use a legend.  The legend tends to take up space, 
and in the case of a graph containing only one data series, the legend serves no purpose; a graph title, that can 
be entered using the Titles tab in Step 4, is more useful for providing information about the data and the graph.   
 

  
Figure 21:  Step 2 Series tab – useful for changing the inputs  
and output, naming the data set, and adding and removing  

data series. 

Figure 22:  Step 2 Series tab – after our data set has been 
named “First Set”. 

 
For graphs containing more than one data series, using a legend and naming the data series is very helpful for 
data and graph manipulation as well as to those reading the graph. 
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Figure 23:  The Titles tab in Step 3. Figure 24:  Step 4 – select the location of the graph. 

 
In Step 3, if you choose to remove the horizontal gridline, you may do so using the Gridlines tab.  The Legend 
can be removed using the Legend tab, and titles and axis labels can be added using the Titles tab, Figure 23.  
Here, the title is added so that I can show you how to modify and remove the title. 
 

 
Figure 25:  The newly generated graph. Figure 26:  The pop-up menu that is displayed when you 

right-click the white region of the graph. 
 
In Step 4, Figure 24, we determine the placement of the graph, on the current sheet or one of the other sheets 
within the workbook, here, sheets 1, 2, and 3, or a new sheet that you can name; the default is “As object in” the 
current sheet, and the default new name is “Chart” numbered from 1. 
 

  
Figure 27:  The pop-up menu that is displayed when you right-

click the grey region of the graph. 
Figure 28:  The pop-up menu that is displayed when you right-

click a gridline. 
 
After clicking Finish in Step 4, the new graph, Figure 25, is generated and placed near the data on the selected 
sheet.  If you like the graph as is, then it is ready for use.  Of course, if you do not, then you will need to modify 
the graph, changing the attributes as desired. 
 
 
Modifying a Graph:  Since I do not like the gray background, the gridlines, the input or the output scales,  the 
placement and orientation of the axis labels, or the title, we will modify the graph.  
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Right-clicking the white region of the graph generates a pop-up menu, Figure 26, that allows us change the 
attributes of the graph area (Format Chart Area), to change the graph type, to access the Source Data, and to 
change the graph options.  Selecting Chart Options allows you to change the elements of Step 3, Titles, Axes, 
Gridlines, Legend, and Data Labels.  So, of course, this would provide one way in which to eliminate the 
gridlines, the legend, and the title. 
 
Right-clicking the grey region of the graph generates a pop-up menu, Figure 27, that allows us to change the 
plot area (Format Plot Area), the graph type, the Source Data, and the graph options.  So, when we need to 
access the sources data or change the graph options or graph type, we can simply right click on the chart or plot 
area. 
 
The easiest way in which to delete the gridlines is to right-click a gridline and then select the Clear option on the 
pop-up menu, Figure 28.  If you choose to keep the gridlines, this same pop-up menu will allow you to access 
the Format Gridlines dialog box in which you can change the weight, pattern, and color of the gridlines as well 
as change the scale on the associated axis.  Needless to say, I used the Clear option to remove the gridlines. 
 

  
Figure 29:  The Format Plot Area Dialog Box. Figure 30:  The Format Chart Area Dialog Box. 

 
Right-clicking the grey region and selecting Format Plot Area on the pop-up menu, opens the Format Plot Area 
Dialog Box, Figure 29, in which we can change the border pattern and color and the color and pattern of the 
Area.  Here, we will remove the border and make the Area white.  It is very important that you are careful when 
you select None for the Area – selecting None makes the plot area transparent.  If you choose to use this 
option, I would suggest that you use it after you have made all of your other graph changes; selecting the parts 
of the graph become difficult when the Plot Area and the Chart Area are transparent. 
 
To change the border on the Chart Area, right-click the Chart Area, the outer region of the graph, and select 
Format Chart Area on pop-up menu.  Notice that having changed the Plot Area color to white, changing the 
Chart Area after that becomes more difficult, especially if you have resized the Plot Area.  So, I suggest that you 
change the Chart Area before you change the plot area; resizing the plot area in between would be beneficial as 
well especially if you plan to make the Chart Area and the Plot Area the same color. 
 
Using the Format Chart Area dialog box, Figure 30, you can change the color, style/pattern, and the weight of 
the border as well as change the color of the Chart Area.  In addition, you can change the font, color, style, and 
size that will be used for the title and the legend.  Here, we only eliminate the border. 
 
So, if you choose not to make any changes to the title, the legend or the axis labels, then in order, 
• modify to the Chart Area,  
• resize the Plot Area (left-click the Plot Area to select it; move the cursor to one of the handles, the black 

rectangles at the corners or middles of the sides, until the cursor becomes a black double-arrow, and then 
left-click, hold, and drag the plot area to the desired size), and then 

• modify the Plot Area, to make things as simple as possible. 
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Figure 31:  The pop-up menus for the Chart Title, the Axis Title, and the 

Legend. 
Figure 32:  The Alignment tab in the Format Axis Title Dialog 

Box. 
 
If you decide to delete chart title, axis labels or the legend, you can do so by left-clicking to select the chart title, 
axis label or legend and then use Cut on the Edit menu, the Delete key, or right-clicking and selecting Clear on 
the associated pop-up menu, Figure 31.  To change the location of the chart title, the axis titles, or the legend, 
simply left-click the chart title, the axis title, or the legend and drag it to the desired location.  The format option 
on these pop-up menus can be used to change the alignment, patterns and font for the associated item.  In 
addition to right-clicking and selecting the associated Format option on the pop-up menu, the format dialog 
boxes can also be opened by double-clicking the chart title, the axis title, or the legend..   
 
Using the Alignment tab of the Format Axis Title Dialog Box, Figure 32, we fix the orientation of the y-axis label; 
this label is always written vertically along the left-hand side of the plot area. 
 

 
Figure 33:  The Format Axis Dialog Box. Figure 34:  The modified graph. 

 
Using the Format Axis dialog box, we can change the font for the scale, change the axis markers, the alignment 
of the markers, the axis pattern, and the scale.  In Figure 33, we change the x-axis minimum value to –5, the 
maximum value to 5, and the major unit to 1.  As with the other Format dialog boxes, this one can be opened by 
right-clicking and selecting the appropriate entry on the pop-up menu or by double-clicking. 
 
So, making the various changes produces our modified graph in Figure 34.  Having modified our graph, there is 
one more thing to discuss, how to easily add  data series to a graph. 
 
 
Adding a Data Series to a Graph:  Rather than using Copy/Paste to add a data series to our graph, we will use 
the Source Data option.  However, we must know where our data is.  I entered the second data series on Sheet 
2 in columns A and B between rows 1 and 101, inclusive.  Opening the Source Data dialog box, Figure 35, by 
right-clicking either the Chart Area or the Plot Area, we see the format of the x-values and y-values of the series, 
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=Sheet1!$A$1:$A$101, following an equal sign we need the sheet name, an exclamation point, and then the 
ranges of the data values with the cells specified as fixed cells using dollar signs. 
 

  
Figure 35:  The Series Tab in the Source Data Dialog Box. Figure 36:  The Second Data Series Added. 

 
To add our data series, we select Add to generate a new series, name the data series, if desired, and specify 
the location of the data.  Figure 36 displays the newly added second data set, “Second Set”.  Clicking OK adds 
our second data set to the graph and adds an entry to the legend; of course the title needs to be changed now, 
Figure 37. 
 

 
Figure 37:  Both data series displayed in the graph. Figure 38:  Right-clicking a curve generates this pop-up 

menu. 
 
Using the Location… entry in the pop-up menus in Figure 26 and Figure 27, we can move the graph, if desired 
to another sheet.    If we are creating graphs that we want to include in documents, it is helpful to have easy 
access to the graph and the corresponding data:  we would want to place the graph on the same page as the 
data so that we can modify the data and the graph easily.  If we are creating a MS Excel document to be used 
by students as part of an assignment, the placement of the graph will depend on what we would like the student 
to be able to see.  It is important to remember that if we want the user to be able to access both the graph and 
the data elements on the worksheet then we must make these elements easy to access:  putting the graph and 
the corresponding data on the same worksheet may be best. 
 
Changing the appearance of the curves is helpful for graph comparison.  To do this, we right-click the desired 
curve and select Format Data Series on the pop-up menu, Figure 38.  We can change the type of Line as well 
as the Weight, Style, and Color and choose to include or not include Markers for the individual data values, 
setting both their Foreground and Background colors, on the Patterns tab.  It is important to note that Markers 
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are best for a small number of data values rather than for closely spaced data values; the same can be said for 
Data Labels. 
 

 
Figure 39:  Changing the Curve for the First Data Series. Figure 40:  Changing the Curve for the Second Data Series. 

 
Then, we change the desired attributes of the curves as desired, Figures 39 and 40.  Here, we change the color 
of each curve, setting one to have a solid blue thicker curve, Figure 39, and the other to have a lighter weight 
broken red curve, Figure 40. 
 

Figure 41:  Our New Graph. Figure 42:  The second curve modified by changing the 
parameters. 

 
Finally, after completing our graph modifications, Figure 41, we can see the benefits of using the fixed cells for 
our parameters since we can change the second curve by simply changing the parameter values, Figure 42. 
 
As discussed, right-clicking the graph allows us to access pop up menus for graph components that we may 
want to modify.  In order to easily access the pop up menu for the desired graph component, we can use the 
textboxes that MS Excel provides.  As we move the cursor over the graph, MS Excel displays a textbox that 
indicates the component that will appear at the top of the pop up menu that will be displayed when we right-click 
the graph, for example right-clicking the graph displayed in Figure 34 would produce a pop up menu that would 
allow us to open the Format Plot Area dialog box; double left-clicking the plot area would open the Format Plot 
Area dialog box as well.  These textboxes are helpful when we want to format components such as specific data 
series and the axes for the graph. 
 
It is important to consider effective color contrast for those with partial sight or visual impairments and the size of 
worksheet elements for those with motor skills limitations/impairments.  Darker colors are easier to see as are 
thicker lines/curves, and small elements/icons can be difficult for those with partial sight or visual impairments to 
see; if you would like to learn more about effective use of color contrast, please visit 
http://www.lighthouse.org/color_contrast.htm.   
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