An Introduction to Winplot

Sarah Mabrouk, Framingham State College

Winplot is a free program that can be downloaded from http://math.exeter.edu/rparris/winplot.html.
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Winplot for Windows 95/98/ME/2K/XP (547K) (6 May 2005)

Winplot is a general-purpose plotting utility, which can draw (and animate) curves and surfaces presented in a varisty of formats. Although this program is meant to

closely resemble the old Windows 3.1 wersion, it is ible with it, meaning that neither program can open files created by the other. This version includes

several improvements, and petwork versions are available.

Supplementary material (23 Mar 2005 ) This means animations, tutorials, teaching modules, and a font. Donated mostly by Winplot users

Foreign-language versions:

Dutch (prepared with the help of Max Blommestiin and Tos Rermiin) (24 Apr 2005 )

French (prepared with the help of David Lemay, Marcel Druwé, and Jean-Tdarc Genevey) (24 Apr 2005 )

Getman (prepared with the help of Dietmar Strube) (24 Apr 2005 )

Hungarian (prepared with the help of Peter Csiba (24 Apr 2005 )

Ttalian (prepared with the help of Cristiano Diane' (24 Apr 2005 )

Portuguese (prepared with the help of Adelme Ribeiro de Jems) (24 Apr 2005 )

Slovak (prepared with the help of Peter Michalicka) (24 Apr 2005 )

Spanish (prepared with the help of Martin Acosta) (24 Apr 2005 )

6 May: Oops| Yesterday's updates were incorrectly compiled, causing some menu items to be grayed sut. Serry for the inconvenience, but down load again.

5 May: The increased resclution feature installed on 10 March can new be disabled by those users who weuld rather not have the added file size. In addition, it is

now possible to assign a filename to the graphical display, using the Windows enhanced metafile format. In 3D, many users were being mystified by the strange

effects caused by not specifying a bounding box for sequences and differential ecuations, since the default examples install rather large boxes. The program now

prompts the user for box information when the example is first created, just as it dees for implicit examples.

24 Apr: Tt was possible for 3D z-axis Tours to cause aloss of system resources. A repair has been made o
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Figure 1: Winplot download.

Left-clicking the Winplot hyperlink at the top of the page, opens the Opening wp32z.exe dialog box. In
order to install the program, you will need to save the zipped Winplot program file, wp32z.exe to your
hard drive: select Save to disk in this dialog box and then click OK, use the Save in pull down menu to
navigate to the folder in which you would like to save the file, and then click Save.
download will begin automatically; it will take several minutes to download this program if you are using a
dial-up connection. It is important to take note of the folder into which you save the program file so that
you will be able to install it; you may find it helpful to create a folder such as the one used in Figure 3,

My_Download_Programs.
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Figure 2: The Opening wp32z.exe dialog box.

Figure 3: The enter name of file to save to dialog box.

Once the download is complete, you can unzip the program file: use Windows Explorer to navigate to the
folder in which you saved the program file and double-click the program name/icon, wp32z.exe, within the
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folder window. The WinZip Self-Extractor, Figure 4, will automatically open and the folder peanut will be
generated on the hard drive; for most computers this file will be generated on the C-drive. If you prefer to
choose another folder name or location, you may do so by clicking Browse and then using the Browse for
Folder dialog box, Figure 5, to locate the folder that you desire; in general, it is best to use the program
designated folder and location unless you already have a folder of the same name in the selected
location.
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Figure 4: The WinZip Self-extractor dialog box. Figure 5: The Browse for Folder dialog box.

Once you have selected the location to which extract the program, you can select Unzip. Upon selecting
Unzip, the folder peanut will be created on the C-drive and the winplot.exe program will be saved within
this folder, Figure 6.
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Figure 6: The peanut folder containing the Winplot program file. Figure 7: The Winplot program window.

Now that you have unzipped the program file, you are ready to “install” the Winplot. The program does
not “install” as other programs but rather is opened/launched each time the program file is executed by
double-clicking the program filename/icon in the peanut folder or by double-clicking a program shortcut
that you add to the start menu or put on the desktop or in the taskbar; to create a program shortcut,
simply right-click the program filename/icon in the peanut folder and drag the shortcut icon to the desired
location, the desktop, start menu, or taskbar. Upon executing the winplot.exe program file, a Winplot
window immediately opens, Figure 7. You are now ready to begin to explore Winplot!

While you could select to save the winplot.exe program file to the desktop, if you were to accidentally
delete this file, you would delete the program. If you do not delete the original zipped program file then
you can extract the program again. However, if you did delete the zipped program file, wp32z.exe, and
the executable program file, winplot.exe, then you would need to download the zipped program file,
wp32z.exe, and extract the program file, winplot.exe again. Creating a Winplot shortcut to winplot.exe will
eliminate the possibility that you accidentally delete executable program file, and the Saving the zipped
program file, wp32z.exe, will enable you to extract winplot.exe if you do accidentally delete the executable
program file. In short, better safe than sorry; of course, you can always download the program again and
you should check the Winplot page, http://math.exeter.edu/rparris/winplot.html, for updates.
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Figure 8: The Winplot Window menu. Figure 9: The Winplot Help menu.

Selecting the Window menu, Figure 8, provides you access to two-dimensional and three-dimensional
graphing windows, the Guess option for exploring graphs, the Mapping option, and the Planets option
which will also allow you to explore direction fields for first order differential equations. Selecting the Help
menu, Figure 9, provides access to the general program help information using the Help option as well as
the general program information through the About option; each program window has its own help
information.

Let us begin by examining the Guess option on the Window menu. We begin with the Guess option since
this is a nice tool for students to use in familiarizing themselves with various function types and function
equations. In addition, exploring the Guess option provides a gentle introduction to some Winplot
options/features. Selecting Guess on the Window menu opens the guess my equation window, Figure
10. Using Guess and Answer on the Equa menu, Figure 11, allows the user to input a “guess” for the
equation corresponding to the displayed graph and to obtain the correct “answer” — the actual function
equation — corresponding to the displayed graph, respectively; the guess my equation dialog box and an
answer box are displayed in Figure 19.

!Eguess my equation !E[ E

File Egua View Btns Misc Help

Mew example  F2
GUEss .. F4
Answer .., FS
Select .. F&
Select all
Reset
Help ...
Figure 10: The guess my equation window. Figure 11: The Equa menu.

Select on the Equa menu allows the user to select the function type, Figure 14. The available function
types are polynomial, rational, trigopnometric, exponential, logarithmic, power, and absolute value.

The View menu, Figure 12, allows the user to control where the axes are displayed within the graph
window using the View option, the magnification using the Zoom option, the grid type, rectangular or polar
as well as the axes/scale options by selecting Grid to open the grid dialog box, Figure 15, and change the
axis and grid lines using the Axes and Grid menus, respectively, Figure 16, as well as alter the graph
display using the Connected dots option.

© 2006 Sarah L. Mabrouk 3
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Figure 12: The View menu. Figure 13: The Btns and Misc menus, respectively

The XY cords LB Recent RB option on the Btns (buttons) menu allows the user to displays the xy
coordinates of any pixel on which (s)he left-clicks and to re-center the graph window on any pixel on
which (s)he right-clicks. By exploring various points displayed on a graph, for example the x-intercept,
the y-intercept, and other characteristic points for various graph types, the user can determine the
function equation that can be entered in the guess my equation dialog box and checked against the
actual function equation displayed in the answer box, Figure 19.
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Figure 14: The enable types dialog box. Figure 15: The grid dialog box.

With the Text option selected, right-clicking on the graph opens the edit text dialog box, Figure 17, which
allows the user to add text with or without an opaque background, to select the angle at which the text is
to be displayed as well as the font, type, size, and color, to what the text is “tied”, and left-clicking and

dragging the text allows the user to position the text within the window; an example is provided in Figure
18.
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=
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Figure 16: The Axes and Gridlines submenus. Figure 17: The edit text dialog box.

The Misc menu contains a Delete text option that allows the user to delete text that has been added to
the graph; right-clicking the text when the Text option has been selected and deleting the text within the
edit text dialog box allows the user to delete the text as well.
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Figure 18: An example of a guess my equation graph with text. Figure 19: The guess my equation dialog box and an answer box.
The Misc menu allows the user to select fonts and colors for graph items using the Fonts and Colors
submenus, Figure 20, and to select the number of decimal places to be displayed; the Decimal places
option on the Misc menu opens the format dialog box, Figure 21.

Curve ...
GUEss ...
Asympokes .., format B
Tables ...
Coordinates ... Background ... decimal places IE—
Coordinates ...
Scale on axes ...
Hyphen ko minus ... Dotted line color ... cancel |
Fi symbal ... Color them

Figure 20: The Fonts and Colors submenus. Figure 21: The format dialog box.
Examining the Equa menus for 2-dim and 3-dim graphing, Figure 22, we see that the user can select the
equation type, for example, explicit, parametric, and implicit, as well as points, segments, recursive
equations and differential equations, and user defined functions for each, lines and polynomials for 2-dim
graphing and planes for 3-dim graphing. The Library contains information about the functions recognized
by the program as well as the appropriate syntax.

1. Explicit ... F1 1. Explicit ... F1
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Figure 22: The Equa menu for 2-dim and 3-dim graphing. Figure 23: The View menu for 2-dim an 3 dim graphing.

The View menus, Figure 23, can be used to select desired window options for the 2-dimand 3-dim
graphs.

© 2006 Sarah L. Mabrouk 5



Let us create a two-dimensional graph: to do this we select 2-dim on the Window menu or use function
key F2. Suppose we would like to graph y =sinx and the first three derivatives. We must first enter the
function equation by opening the y =1f(x) dialog box using the Explicit option on the Equa menu or
function key F1. In the y =f(x) dialog box, Figure 24, we enter the function equation, set the maximum
and minimum values X, select the pen width and the point density for the curve as well as the step
tolerance (useful for discontinuities) and the color; the curve dialog box, Figure 24, opens when you click
the color button in the y = f(x) dialog box. Here, the function, y = sinx , will be in red with a pen width of
1, the first derivative will be in blue with a pen width of 2, the second derivative will be lime green with a
pen width of 3, and the third derivative will be pink with a pen width of 4. We add the derivative functions
using the inventory dialog box, Figure 25, that opens once you select ok in the y =f(x) dialog box. The
derive button adds a derivative of the original function entered for each time that you click the button. As
you add derivatives of the original function to the graph, each derivative is listed in the inventory dialog
box and the attributes for each can be set using the edit button; a y =f(x) dialog box for each curve

opens when you click the edit button for the selected (highlighted) equation. The function equations can
be added to the graph using the show equation button for each selected (highlighted) equation.

y = f{x) E inventory for nonameb.wp2 E3
- ¥ = sin(x)
il = [linl)

derl{y = sin(=)}

[~ lock interval ™ make periodic _ derZ{y = sinix)}
lowx |-5.00000 Close =
high » |5.00000
o - N
pen width |1 plotting density |1
colar | step tolerance I‘I'DD edit I delete | dupl | clip | table | fammily I
ok I cancel | help | hide graphl show equal name | derive | web I
Figure 24: The y = f(x) dialog box and color select dialog box. Figure 25 The inventory dialog box.

In Figure 26, we see the graphs of y =sinx and the first three derivatives, each with the specified color
and pen width as well as the associated labels in corresponding colors.

! nonameb.awp2 !E E

File Equa Yiew Btns One Two Anim  Misc
¥ o= Sinix)
derli{y = =in(x]} <+

deri{y = sin(x)}
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¥ = sinfax) fa v[=a = 0.000 to 1.000;
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parameter IE [A..03] j

1 low [0.00000
edit | high [1.00000 fc"m”l*|

hide graph ~ steps |5 e

IV watch delay |5
£ define | undefinel

Figure 26: The graphs of y = sinx with the first three derivatives. Figure 27: The family dialog box.
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The dupl. button in the inventory dialog box, Figure 25, can be used to add duplicate function curves. All
attributes including the function equations for the duplicate functions of the original (non-derivative)
function equation can be edited. However, only the display attributes, not the equations, for duplicate
curves of derivative functions can be edited.

To create a family of curves with one parameter, we enter the function equation using the desired
parameter, here y = sinax with parameter a, using the Explicit option on the Equa menu or F1 as before

and then set the maximum and minimum values of the parameter as well as the number of steps (one
less than the number of curves to be displayed); using values given in Figure 27, six curve will be
displayed with five steps in the value of the parameter a from 0 to 1, that is, the values of a are 0, 0.2, 0.4,
0.6, 0.8, and 1.0.

Now, let us make a graph in 3-space. To do this, we select 3-dim in the Window menu or press function
key F3. This opens a graph window displaying the x-axis, y-axis, and z-axis, Figure 28. To generate a
specific graph, we select an option on the Equa menu as we did for 2-dim graphing. Here, let us select
Parametric and let us graph the elliptic spiral determined by the vector-valued function of one variable
r(t) = sinti —3costj + 2tk .

,!. noname3.wp3 Sz !

Filz Equa Yiew Btns ©One Two Anim  Misc

z

surface x{t,u), y(t,u), 2{t,u)

w= =Nt

y=|3cost)

z= |2t

tlo=[2000000 | divisions |F
thi= W slice ptz W

ulo = |-5.00000 divisions |50
u hi = [5.00000 zlice ptz | 200
color | pen width |1

[~ fast draw [ spectum [ grid
[~ shade  call | col 2 | color |

ok I cancell help |

Figure 28: The 3-dim graph window. Figure 29: The surface dialog box.

Selecting the Parametric option on the Equa menu opens the surface dialog box, Figure 29; examining
the surface dialog box, we see that we can graph functions containing two parameters, t and u. Since for
our elliptic spiral, r(t) = sinti —3costj+ 2tk , x =sint, y =-3cost, and z = 2t, we enter these for x, y, and

z, respectively. Experimenting with the divisions for this function, you will find that the maximum number
of divisions that you can use is 57. Examining Figures 30 and 31, we see the difference between using
and not using the fast draw option within the surface dialog box.

Since we have discussed several graphs, this would be a nice point at which to mention the background
color options available on the Misc menu; these options as well as others specific to each window are
included in the Misc menus. Using this option, we can change the background from its current gray to
another color, for example, white. As for changing other color options, a color dialog box similar to that
displayed in Figure 24 opens and the user can select her/his desired color. Using different colors for the
background and gridlines for 2-dim graphing will, of course, be helpful for exploring graphs.

© 2006 Sarah L. Mabrouk 7
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Figure 30: The graph of r(t) = sinti — 3costj + 2tk generated
using the fast draw option in the surface dialog box.

Figure 31: The graph of r(t) = sinti — 3costj + 2tk generated
without using the fast draw option in the surface dialog box.

Now let us graph a hyperboloid of two sheets, z*> —x* —y®> =1. To do this, we use the Implicit option on

the Equa menu and enter the equation in the implicit surface dialog box, Figure 32. After we click Ok, the
dimensions of box dialog box, Figure 32, opens: we use this dialog box to set up the box, the x-, y-, and
z-intervals, for the graph of the function. Upon clicking Ok, no graph is generated: we must open the
inventory dialog box using the Inventory option on the Equa menu and generate the level curves.

level curves for z*

|3? levelvaluesfor  C x Cy & 2 |3? levelvaluesfor Oy 0z
low |-5.00000 low |-5.00000
prev level prev level
curr |-5.00000 curr |5.00000
high [5.00000 _rexlews | high [5.00000 _nestlevel |
color | search curm | auto | caolor search cur | auto |
i g wvel curve
[1.75582,1.90609,2.77778) z-level curve
[1.99577 -1.65316,2.77778) z-level curve
[1.99577 -1.65316,2.77778) z-level curve
M 7NRAN -1 AROM 2 777781 #lewel rurve T
| | | “ »
seecunl see all | delonel del all | Seecunl see all | delunel del all |
keep changes I discard changesl keep changes | dizcard changesl

dimensions of box [ x|
|5 <x< 5
Iz‘2-x“2-y“2=1 |-5 <pe |5
Bl <24 |5
colar pen width |2 I € I
I lock pasition ¥ clip trajectories
ok I cancel | help | e — |
Figure 32: The implicit surface dialog box and the dimensions
dialog box.

Figure 33: The level curves dialog box before and after
automatically generating the level curves.

In the level curves dialog box, we must set the low, current, and high values for the level curves for one
variable; here, Figure 33, these values are set as -5, -5 (the first value), and 5, respectively. Then, we
click auto to automatically generate these values. As the level curves are generated, they are displayed
in the levels window that is automatically displayed, Figure 34. Selecting see all in the level curves dialog
box, allows the user to view all the level curves in the levels window, the right-hand image in Figure 34.
We select keep changes to complete the process and to generate the graph, Figure 35.

Using the Axes option on the View menu, we can select to display or not display the axes and axis labels
as well as edit the axis labels and change the fonts and the colors for the axis labels.

© 2006 Sarah L. Mabrouk
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Figure 34: The levels for the graph display rapidly and the levels
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Other options such as Zoom, Rotate, and Observer are also available on this menu. These can be used
to change the zoom factor, the angle at which the graph is displayed, and the view for the observer.

zh2-x*2-y*2=1 zh2-x*2-yh2=1
x*tzZ-zt2-yh2=1
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Figure 36: The picture image for the graph of z° - x* —y* =1 Figure 37: The picture image for the graphs of z° —x* —y* =1

inserted using Paste Special in MS Word. and X' -2 —y* =1,

Once you have generated a graph that you would like to include in a document, you can choose the
image size using the Image size option on the File menu and copy the image using the Bitmap to
clipboard option on the File menu.

It is important to mention that using a bitmap increases the size of the file into which you copy the image.

If you are using MS Word, a handy trick that will help to keep your files of manageable size is to cut the
image, Cntrl X, and then use Paste Special to paste in the image as a picture. You will also notice a
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difference in the sharpness of the image for a picture in comparison to a bitmap — the picture image is
sharper.

It can be helpful to view multiple graphs in the same graph window as in Figure 37. If, for example, the
user wants to view the level curves for x, y, and z, (s)he can select each variable individually and
generate the level curves in the same way as previously discussed. Selecting keep changes in the levels

dialog box after the desired level curves have been generated will produce a graph similar to that of
2

x* —z* —y® =1 displayed in Figure 37.
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Figure 38: The 2-dim differential equation dialog box and the Figure 39: The 2-dim slope field for the differential equation
inventory dialog box for the differential equation d_y =X-Y. ﬂ =X-Y.
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Figure 40: The ivps dialog box. Figure 41: The picture of the graph of the slope field for
d
Y = X —y with six trajectories.
dx
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Finally, let us examine the slope field and some trajectories for the differential equation % =x-y. Todo
this, we select Differential on the Equa menu and enter the differential equation and desired options such
as color, number of horizontal rows, and pen width in the differential equation dialog box. Then, to view
trajectories for this differential equation, we select dy/dx trajectory on the One menu. The user can enter
the coordinates of the desired initial value or left-click on the slope field to select the initial value; a
different color, pen width, and numerical integration method, Euler, Modified Euler, or Runge-Kutte, may
be chosen for each trajectory as generated. As the trajectories are generated, they are displayed in the
ivps dialog box, Figure 40, and the trajectories are displayed in the graph window, Figure 41. Using the
delete button in the ivps dialog box, individual trajectories can be deleted or all trajectories can be deleted
using the delete all button.
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Figure 42: The ivps dialog box used to generate the trajectories Figure 43: The picture of the graph of the vector field and
dx dy trajectories for the system of differential equations
for the system of differential equations — = x* -y, — = 2x -y’ x dy )
dt dt —:X,y’—ZZX,y
dt dt

In a similar manner but using the dy/dt option on the Differential submenu of the Equa menu, we can

generate the direction field for the system of differential equations % =x’ -y, (;—3:: 2x —y?; Figure 42
displays the ivps dialog box and Figure 43 displays the picture for seven trajectories and the direction

dy _
dt
(here, set to 1) in the Misc menu or limiting the duration within the ivps dialog box can be used to avoid
infinite loops within trajectories; without using at least one of these limitations, Winplot will not end a loop
within a trajectory.

field for the system of differential equations % =x%-y, 2x —y®. Setting the loop closing tolerance

VA

| hope that you have found this introduction to Winplot helpful. There are more settings and capabilities
to explore — the best way in which to learn this program, as with others, is to simply “play” with it. Please
remember to save your “explorations” since you may find them to be helpful/useful in the future.

| hope that you found this handout helpful. Please feel free to contact me, smabrouk@frc.mass.edu, if
you have any questions.
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